Running this file in KDE Neon Wayland. Dependencies not found.

Description

Software librepilot_16.09+r589_g4c9c3c2-0artful1_amd64.deb when trying to run gets dependencies error. When I try to install those dependencies it says mine are newer and cancels out.

Environment

Linux version 4.13.0-32-generic (buildd@lgw01-amd64-004) (gcc version 5.4.0 20160609 (Ubuntu 5.4.0-6ubuntu1~16.04.5)) #35~16.04.1-Ubuntu SMP Thu Jan 25 10:13:43 UTC 2018

Activity

Show:
Lalanne Laurent
February 20, 2018, 6:28 PM

Your Ubuntu seems based on 16.04.1 (Xenial) so you should try to install the matching package or add the 'next' repository as described wiki page.
The package you mention is compiled for Ubuntu Artful.

Jason LaMar
February 21, 2018, 12:40 AM

I've tried them all I redownloaded librepilot_16.09+r589_g4c9c3c2-Oxenial1_amd64.deb

I wonder if its my kernal being wayland and not x11?

rockrdr@neon:~$ sudo add-apt-repository ppa:librepilot/next
[sudo] password for rockrdr:
Packages from Next branch
More info: https://launchpad.net/~librepilot/+archive/ubuntu/next
Press [ENTER] to continue or ctrl-c to cancel adding it

gpg: keyring `/tmp/tmp7shpstek/secring.gpg' created
gpg: keyring `/tmp/tmp7shpstek/pubring.gpg' created
gpg: requesting key 45DC3732 from hkp server keyserver.ubuntu.com
gpg: /tmp/tmp7shpstek/trustdb.gpg: trustdb created
gpg: key 45DC3732: public key "Launchpad PPA for LibrePilot" imported
gpg: Total number processed: 1
gpg: imported: 1 (RSA: 1)
OK
rockrdr@neon:~$ sudo apt-get update
Hit:1 http://us.archive.ubuntu.com/ubuntu xenial InRelease
Hit:2 http://download.virtualbox.org/virtualbox/debian xenial InRelease
Ign:3 http://dl.google.com/linux/earth/deb stable InRelease
Hit:4 http://us.archive.ubuntu.com/ubuntu xenial-updates InRelease
Hit:5 http://download.virtualbox.org/virtualbox/debian zesty InRelease
Hit:6 http://dl.google.com/linux/earth/deb stable Release
Hit:7 http://archive.canonical.com/ubuntu xenial InRelease
Get:8 http://security.ubuntu.com/ubuntu xenial-security InRelease [102 kB]
Get:9 http://ppa.launchpad.net/librepilot/next/ubuntu xenial InRelease [18.0 kB]
Hit:10 http://repo.steampowered.com/steam precise InRelease
Get:11 http://us.archive.ubuntu.com/ubuntu xenial-backports InRelease [102 kB]
Ign:12 http://download.opensuse.org/repositories/home:/strycore/Debian_9.0 ./ InRelease
Hit:14 http://download.opensuse.org/repositories/home:/strycore/Debian_9.0 ./ Release
Hit:15 http://ppa.launchpad.net/librepilot/release/ubuntu xenial InRelease
Get:17 http://archive.neon.kde.org/user xenial InRelease [31.1 kB]
Hit:18 http://ppa.launchpad.net/librepilot/tools/ubuntu xenial InRelease
Hit:19 http://ppa.launchpad.net/niko2040/e19/ubuntu xenial InRelease
Fetched 253 kB in 1s (145 kB/s)
Reading package lists... Done
W: Target Packages (main/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list.d/librepilot-ubuntu-tools-xenial.list:1 and /etc/apt/sources.list.d/librepilot-ubuntu-tools-xenial.list:3
W: Target Packages (main/binary-i386/Packages) is configured multiple times in /etc/apt/sources.list.d/librepilot-ubuntu-tools-xenial.list:1 and /etc/apt/sources.list.d/librepilot-ubuntu-tools-xenial.list:3
W: Target Packages (main/binary-all/Packages) is configured multiple times in /etc/apt/sources.list.d/librepilot-ubuntu-tools-xenial.list:1 and /etc/apt/sources.list.d/librepilot-ubuntu-tools-xenial.list:3
W: Target DEP-11 (main/dep11/Components-amd64.yml) is configured multiple times in /etc/apt/sources.list.d/librepilot-ubuntu-tools-xenial.list:1 and /etc/apt/sources.list.d/librepilot-ubuntu-tools-xenial.list:3
W: Target DEP-11-icons (main/dep11/icons-64x64.tar) is configured multiple times in /etc/apt/sources.list.d/librepilot-ubuntu-tools-xenial.list:1 and /etc/apt/sources.list.d/librepilot-ubuntu-tools-xenial.list:3
W: Target DEP-11-icons-hidpi (main/dep11/icons-64x64@2.tar) is configured multiple times in /etc/apt/sources.list.d/librepilot-ubuntu-tools-xenial.list:1 and /etc/apt/sources.list.d/librepilot-ubuntu-tools-xenial.list:3
W: Target DEP-11-icons-large (main/dep11/icons-128x128.tar) is configured multiple times in /etc/apt/sources.list.d/librepilot-ubuntu-tools-xenial.list:1 and /etc/apt/sources.list.d/librepilot-ubuntu-tools-xenial.list:3
N: Skipping acquire of configured file 'main/binary-i386/Packages' as repository 'http://dl.google.com/linux/earth/deb stable InRelease' doesn't support architecture 'i386'
W: Target Packages (main/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list.d/librepilot-ubuntu-tools-xenial.list:1 and /etc/apt/sources.list.d/librepilot-ubuntu-tools-xenial.list:3
W: Target Packages (main/binary-i386/Packages) is configured multiple times in /etc/apt/sources.list.d/librepilot-ubuntu-tools-xenial.list:1 and /etc/apt/sources.list.d/librepilot-ubuntu-tools-xenial.list:3
W: Target Packages (main/binary-all/Packages) is configured multiple times in /etc/apt/sources.list.d/librepilot-ubuntu-tools-xenial.list:1 and /etc/apt/sources.list.d/librepilot-ubuntu-tools-xenial.list:3
W: Target DEP-11 (main/dep11/Components-amd64.yml) is configured multiple times in /etc/apt/sources.list.d/librepilot-ubuntu-tools-xenial.list:1 and /etc/apt/sources.list.d/librepilot-ubuntu-tools-xenial.list:3
W: Target DEP-11-icons (main/dep11/icons-64x64.tar) is configured multiple times in /etc/apt/sources.list.d/librepilot-ubuntu-tools-xenial.list:1 and /etc/apt/sources.list.d/librepilot-ubuntu-tools-xenial.list:3
W: Target DEP-11-icons-hidpi (main/dep11/icons-64x64@2.tar) is configured multiple times in /etc/apt/sources.list.d/librepilot-ubuntu-tools-xenial.list:1 and /etc/apt/sources.list.d/librepilot-ubuntu-tools-xenial.list:3
W: Target DEP-11-icons-large (main/dep11/icons-128x128.tar) is configured multiple times in /etc/apt/sources.list.d/librepilot-ubuntu-tools-xenial.list:1 and /etc/apt/sources.list.d/librepilot-ubuntu-tools-xenial.list:3
rockrdr@neon:~$ sudo apt-get install librepilot
Reading package lists... Done
Building dependency tree
Reading state information... Done
Starting pkgProblemResolver with broken count: 1
Starting 2 pkgProblemResolver with broken count: 1
Investigating (0) librepilot [ amd64 ] < none -> 16.09+r590~ga6b2bf4-0xenial1 > ( electronics )
Broken librepilot:amd64 Depends on qtdeclarative-abi-5-5-0 [ amd64 ] < none -> > ( none )
Considering libqt5qml5:amd64 437 as a solution to librepilot:amd64 9999
Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
librepilot : Depends: qtdeclarative-abi-5-5-0
E: Unable to correct problems, you have held broken packages.
rockrdr@neon:~$

If I try installing the qtdeclarative-abi-5-5-0 I get a newer version installed.

"libqt5qml5 is already the newest version (5.9.3-0neon+16.04+xenial+build32).
Starting pkgProblemResolver with broken count: 0"

Thank You

Lalanne Laurent
February 21, 2018, 11:17 AM

Seems your neon.kde.org repository add qt5.9.3 where the default qt version is 5.5.1 (yes, quite old) in official Ubuntu xenial we use for automatic builds and xenial/next repo.
The artful package uses qt5.9.3 but will fails with others dependencies not found because you run 16.04.

In this situation we cannot provides a ready to install package for your Xenial + qt5.9.3
One alternative is setup a build environment like described here or try to run the AppImage version.

Assignee

Unassigned

Reporter

Jason LaMar

Labels

None

Components

Affects versions

Priority

Highest
Configure